Placed

100 mg sildenafil

Free Cisco Lab GNS3 Scenario Basic OSPF

Posted by: admin  :  Category: CCNP, OSPF




In this Free Cisco Lab GNS3 Scenario I’ll show you how to configure a simple multi area OSPF network using four routers.

As per the network diagram we will have 3 OSPF area’s, our backbone area 0, and area’s 10 and 20. Routers R1 and R2 are both known as an Area Border Router’s (ABR) because they are both on the border between two area’s.

The first thing we need to do is configure the interfaces with IP addresses. (Assumed, hostname and base config is already complete):

  • R1(config)#interface fastethernet 0/0
  • R1(config-if)#ip address 10.0.0.2 255.255.255.252
  • R1(config-if)#interface serial 0/0
  • R1(config-if)#clockrate 64000
  • R1(config-if)#ip address 10.1.1.1 255.255.255.252
  •  
  • R2(config)#interface fastethernet 0/0
  • R2(config-if)#ip address 10.1.1.2 255.255.255.252
  • R2(config-if)#interface serial 0/0
  • R2(config-if)#clockrate 64000
  • R2(config-if)#ip address 10.2.2.1 255.255.255.252
  •  
  • R3(config)#interface serial 0/0
  • R3(config-if)#ip address 10.0.0.1 255.255.255.252
  • R3(config-if)#interface fastethernet 0/0
  • R3(config-if)#ip address 192.168.1.1 255.255.255.0
  •  
  • R4(config)#interface serial 0/0
  • R4(config-if)#ip address 10.2.2.2 255.255.255.252
  • R4(config-if)#interface fastethernet 0/0
  • R4(config-if)#ip address 172.16.1.1 255.255.0.0 

Make sure you bring your interfaces up with no shutdown.

Next we’ll configure our backbone OSPF area 0:

  • R1(config)#router ospf 1
  • R1(config-router)#router-id 1.1.1.1
  • R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
  • R1(config-router)#network 10.0.0.0 0.0.0.3 area 10
  •  
  • R2(config)#router ospf 1
  • R2(config-router)#router-id 2.2.2.2
  • R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
  • R2(config-router)#network 10.2.2.0 0.0.0.3 area 20
  • We’ll then complete the OSPF config for Area 10:
  • R3(config)#router ospf 1
  • R3(config-router)#router-id 10.10.10.10
  • R3(config-router)#network 10.0.0.0 0.0.0.3 area 10
  • R3(config-router)#network 192.168.1.0 0.0.0.255 area 10
  • R3(config-router)#interface loopback 0
  • R3(config-if)#ip ospf network point-to-point
  • We’ll the complete the OSPF config for Area 20:
  • R4(config)#router ospf 1
  • R4(config-router)#router-id 3.3.3.3
  • R4(config-router)#network 10.2.2.0 0.0.0.3 area 20
  • R4(config-router)#network 172.16.0.0 0.0.255.255 area 20
  • R4(config-router)#interface loopback 0
  • R4(config-if)#ip ospf network point-to-point

We’ll now test our connectivity and verify our routing tables:

  • R3#ping 172.16.1.1 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/24 ms

The routing table on R3, shows the Interarea (IA) routes to the 10.2.2.0 and 10.1.1.0 subnets. The reason they are IA routes is because R0 itself is not a member of the same area that these subnets are in:

Gateway of last resort is not set 

  • O IA 172.16.0.0/16 [110/4] via 10.0.0.2, 00:44:58, FastEthernet0/0
  •      10.0.0.0/30 is subnetted, 3 subnets
  • O IA    10.2.2.0 [110/3] via 10.0.0.2, 00:44:58, FastEthernet0/0
  • O IA    10.1.1.0 [110/2] via 10.0.0.2, 01:21:09, FastEthernet0/0
  • C       10.0.0.0 is directly connected, FastEthernet0/0
  • C    192.168.1.0/24 is directly connected, Loopback0

The routing table on R2:

Gateway of last resort is not set 

  • O    172.16.0.0/16 [110/2] via 10.2.2.2, 00:45:18, FastEthernet0/1
  •      10.0.0.0/30 is subnetted, 3 subnets
  • C       10.2.2.0 is directly connected, FastEthernet0/1
  • C       10.1.1.0 is directly connected, FastEthernet0/0
  • O IA    10.0.0.0 [110/2] via 10.1.1.1, 00:45:18, FastEthernet0/0
  • O IA 192.168.1.0/24 [110/3] via 10.1.1.1, 00:45:18, FastEthernet0/0

The OSPF neighbors on R2:

  • R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface

  • 1.1.1.1           1   FULL/BDR        00:00:37    10.1.1.1        FastEthernet0/0
  • 3.3.3.3           1   FULL/DR         00:00:32    10.2.2.2        FastEthernet0/1

Download this GNS3 lab: {filelink=17}

Check out these other fantastic training resources:

2 Responses to “Free Cisco Lab GNS3 Scenario Basic OSPF”

  1. Grills Says:

    you taken a crack at ps samurai modchip for playstation 3 slim? this appears to go fine on current 3.5 firmware, should it be the case i’m without a doubt buying one! the web-site is http://www.pssamurai.com

  2. scholarships for high school seniors Says:

    I should say that it’s my first time to visit your blog, however, I can directly say it contains so many useful info.
    Atta boy!

Leave a Reply

What is 8 + 13 ?
Please leave these two fields as-is:
IMPORTANT! To be able to proceed, you need to solve the following simple math (so we know that you are a human) :-)

*

http://s51.sitemeter.com/meter.asp?site=s51ciscolab Site Meter