Terminal Server Configuration Using Cisco Routers
A terminal or comm server provides out-of-band access to multiple devices. A terminal server is essentially a router with multiple, low speed, asynchronous ports that can be connected to the console ports of other devices, such as routers or switches.
The terminal server allows you to use a single point to access the console ports of many devices. A terminal server eliminates the need to move the console cable from device to device. You can also configure a modem on the auxiliary port of the terminal server, to provide dial-up service to many network devices when network connectivity fails.
The Cisco 2509 – 2512 series routers use a CAB-OCTAL-ASYNC to provide eight RJ-45 roll over cable. You can connect each RJ-45 roll over cable to the console port of the managed device. The 2511 router allows for a maximum of 16 devices to be remotely accessible. Alternatively the NM-16A or NM-32A high density async network modules can be installed in the Cisco 2600 and 3600 series routers to provide the same function.
Basic configuration of a terminal server:
router#show running-config
!
version 12.0
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname lab-comm-server
!
enable secret cisco
!
username cisco password cisco
!
ip subnet-zero
no ip domain-lookup
!
ip host R1 2001 10.0.0.1
ip host R2 2002 10.0.0.1
ip host R3 2003 10.0.0.1
ip host R4 2004 10.0.0.1
ip host R5 2005 10.0.0.1
ip host R6 2006 10.0.0.1
ip host V1 2007 10.0.0.1
ip host FR 2008 10.0.0.1
!
!
process-max-time 200
!
interface Loopback1
ip address 10.0.0.1 255.0.0.0
!— This address is used in the IP host commands.
!— Work with loopback interfaces, which are virtual and always available.
no ip directed-broadcast
!
interface Ethernet0
ip address 192.168.1.30 255.255.255.0
!— Use a public IP address to ensure connectivity.
No ip directed-broadcast
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
ip default-gateway 192.168.1.254
!— This is the default gateway when routing is disabled.
!— For example, if the router is in boot ROM mode.
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!— Set the default route for the external network.
no ip http server
!
line con 0
transport input all
line 1 16
session-timeout 20
!— The session times out after 20 minutes of inactivity.
no exec
!— Unwanted signals from the attached device do not launch.
!— An EXEC session ensures that the line never becomes unavailable
!— due to a rogue EXEC process.
exec-timeout 0 0
!— This disables exec timeout transport input all.
!— Allow all protocols to use the line.
!— Configure lines 1 – 16 with at least transport input Telnet.
line aux 0
!— Auxiliary port can provide dial backup to the network.
!— Note: This configuration does not implement modem on AUX port modem InOut.
!— Allow auxiliary port to support dialout and dialin connections.
transport preferred telnet
transport input all
speed 38400
flowcontrol hardware
line vty 0 4
exec-timeout 60 0
password <deleted>
login
!
December 26th, 2010 at 5:51 am
When I commented I clicked the “Notify me when new comments are added” radio button now whenever a comment is made I get a notification!
January 12th, 2011 at 8:31 am
It’s a pity you don’t have a donate button! I’d without a doubt donate to this brilliant blog! I guess for now i’ll settle for book-marking and adding your RSS feed to my Google account. I look forward to fresh updates and will talk about this site with my Facebook group. Chat soon!